Black screen, plugins and New CocoonJs problems


#3

Number 3 error:

The same thing happend with the others.

Nuber 4: When I install Admob plugin there’s a compilation error, so I had to remove Admob for compiling

And the black screen’s still happend. It’s not one of them in the link :disappointed:


#4

Hi @mywaregames
it seems that your plugin is broken, please download the latest plugins over here and delete the “ads” plugin from your C2 plugins folder. I guess that you copied the parent folder, but you must enter the “ads” folder and copy the “cocoon-ads” folder into Construct2/exporter/html5/plugins…

Click on “Download ZIP” and extract the file. Then install it the way shown above and insert the CocoonAds plugin in your c2 project.

With that the blackscreen issue will disappear, too.

Regards
Andy


#5

Oh, thanks dude :wink: I copied the parent folder before, now the plugins are working. Now I just have to fix the black screen problem
Hey, my script of In-App Purchases is using the default IAP Construct2 plugin. Is this still working?


#6

You’re welcome :wink:
Did you also installed the plugins at your project in CocoonIO?
Always install the same plugins on CocoonIO like in your C2 project.
Otherwise this could cause a black issue. You get the error log when you use the Developer App.

No, please use the CocoonInApp plugin for IAP purchases.

Regards
Andy


#7

Do I have to do a store listening request? Because there’s not any event about it :confused:


#8

You find a Code example for construct 2 here :wink:

Just check it out, there you’ll see how to setup the IAP stuff in C2.

Regards
Andy


#9

I got this error:

Sorry for taking your time… =/


#10

Don’t worry, I’m here to help :slightly_smiling:
You must install the Cocoon C2 plugins first.

Please see here: https://shatter-box.com/knowledgebase/cocoonio-how-to-build-a-game-using-construct-2/#document-2

P.S. Never hesitate to ask, I’m here to help you :slight_smile:

Regards
Andy


#11

Hi everyone!

I’m receiving the same error messages, but I’ve unzipped into what I believe is the appropriate path for the plugins:

C:\Program Files\Construct 2\exporters\html5\plugins(respective cocoon-plugin folder)

I have not copied the parent folder, only the sub folder content.

Any ideas what is causing this error? I must be missing something…


#12

Hi @rjblueskies

You are right.
It should look like that.

and the path should be
C:\Program Files\Construct 2\exporters\html5\plugins\...

The content of each plugin should look like that.

If you have another folder in the plugin folder, you will get an error.

Hope this helps.

Regards
Andy


#13

@andy_reitberger Thanks for helping with this!!

Hmm. My icons are appearing differently:

I believe I’ve unzipped correctly. Weird difference though.

Any ideas why this would be happening and if this could be causing the problem?


#14

The icons come from my code editor :wink: Well that’s a good question. Can you post a screen shot of the error message?
Maybe there is a hint.

Thank you!


#15

I’m also receiving this error message for Share and Social. But when I open C2, they’re all there and appear to be available to use. It’s confused me.

Thoughts?


#16

One additional thought: I’ve been trying to use the developer app and it’s always failing to install.

Is it best to just upload to the Google Play Store and test in Alpha? Not ideal since it takes about an hour (or more) each time I upload a new apk…


#17

Hi!
Please make following steps.

  1. Go to your c2 plugin installation folder, mostly:

C:\Program Files\Construct 2\exporters\html5\plugins

  1. Then delete all marked folders (if exists)

  1. Download the attached zip file and unzipp it
    plugins.zip (62.7 KB)

  2. Copy the content “as is” into the c2 plugin folder.

  3. Restart c2 and try again.

Regards
Andy


#18

Thanks! I’ve followed your steps. All of the folders you highlighted previously existed in my plugin installation folder so I deleted them, unzipped the file and copied the unzipped contents as is.

Looks like I’m receiving the same error messages (inapp, share, and social):

But yet, when I open c2 and add a new object:

Just like before, it appears the plugins are available to use, despite the error messages. Weird, huh?

I just tried uninstalling and reinstalling c2 with no success.

Do you think the plugins work since they’re available in c2?


#19

Hi,
sorry for the late respone.
I was a little bit busy the last days.

Now I see what your issue is.
It’s not the “cocoon-inapp” plugin what causes this issue, but the “inapps” plugin.
So go to plugin folder and delete the “inapps” folder.

Then the message should disappear once and for all.

Let me know if it worked.

Regards
Andy


#20

Hah! I should have read the path more closely. I deleted the folders it was referring to and I’m good to go now!

Thanks!!


#21

Awesome :slight_smile: I took me a while as well :wink:

I’ll close this topic then!

Thank you!

Regards
Andy


#22