Build Failed: Error with Google Play Services


#1

I am compiling with simple webview and build failed with error for google play services

Note: i am getting same error with phonegap too

If anyone knows how to solve this then please help…

COMPILER ERROR:

/workspace/platforms/android/gradlew: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • What went wrong:
    A problem occurred configuring root project ‘android’.

Could not resolve all dependencies for configuration ‘:_debugApkCopy’.
Could not find com.google.android.gms:play-services-base:11.8.0.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
Required by:
project : > com.google.android.gms:play-services-games:11.0.4
project : > com.google.android.gms:play-services-games:11.0.4 > com.google.android.gms:play-services-drive:11.0.4
Could not find com.google.android.gms:play-services-basement:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-games:11.0.4
project : > com.google.android.gms:play-services-games:11.0.4 > com.google.android.gms:play-services-drive:11.0.4
project : > com.google.android.gms:play-services-games:11.0.4 > com.google.android.gms:play-services-tasks:11.0.4
Could not find com.google.android.gms:play-services-base:11.8.0.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar
Required by:
project : > com.google.android.gms:play-services-plus:11.8.0
Could not find com.google.android.gms:play-services-basement:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-plus:11.8.0
Could not find com.google.android.gms:play-services-plus-license:11.8.0.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar
Required by:
project : > com.google.android.gms:play-services-plus:11.8.0
Could not find com.google.android.gms:play-services-ads-lite:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-ads:12.0.1
Could not find com.google.android.gms:play-services-basement:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-ads:12.0.1
Could not find com.google.android.gms:play-services-gass:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-ads:12.0.1
Could not find com.google.android.gms:play-services-ads-license:12.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar
Required by:
project : > com.google.android.gms:play-services-ads:12.0.1

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

CORDOVA LOG:

:11.0.4 > com.google.android.gms:play-services-drive:11.0.4\n project : > com.google.android.gms:play-services-games:11.0.4 > com.google.android.gms:play-services-tasks:11.0.4\n > Could not find com.google.android.gms:play-services-base:11.8.0.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-base/11.8.0/play-services-base-11.8.0.aar\n Required by:\n project : > com.google.android.gms:play-services-plus:11.8.0\n > Could not find com.google.android.gms:play-services-basement:12.0.1.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n Required by:\n project : > com.google.android.gms:play-services-plus:11.8.0\n > Could not find com.google.android.gms:play-services-plus-license:11.8.0.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-plus-license/11.8.0/play-services-plus-license-11.8.0.aar\n Required by:\n project : > com.google.android.gms:play-services-plus:11.8.0\n > Could not find com.google.android.gms:play-services-ads-lite:12.0.1.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-lite/12.0.1/play-services-ads-lite-12.0.1.aar\n Required by:\n project : > com.google.android.gms:play-services-ads:12.0.1\n > Could not find com.google.android.gms:play-services-basement:12.0.1.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-basement/12.0.1/play-services-basement-12.0.1.aar\n Required by:\n project : > com.google.android.gms:play-services-ads:12.0.1\n > Could not find com.google.android.gms:play-services-gass:12.0.1.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-gass/12.0.1/play-services-gass-12.0.1.aar\n Required by:\n project : > com.google.android.gms:play-services-ads:12.0.1\n > Could not find com.google.android.gms:play-services-ads-license:12.0.1.\n Searched in the following locations:\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.pom\n file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar\n file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads-license/12.0.1/play-services-ads-license-12.0.1.aar\n Required by:\n project : > com.google.android.gms:play-services-ads:12.0.1\n\n* Try:\nRun with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.\n’,
stdout:
‘The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.\n\tat build_7akeclyxp7k74xkb89oki3be5.run(/workspace/platforms/android/build.gradle:137)\nThe JavaCompile.setDependencyCacheDir() method has been deprecated and is scheduled to be removed in Gradle 4.0.\nIncremental java compilation is an incubating feature.\nThe TaskInputs.source(Object) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use TaskInputs.file(Object).skipWhenEmpty() instead.\n\nBUILD FAILED\n\nTotal time: 2.48 secs\n’,
code: 1 }
If anyone knows how to solve this then please help…


#2

Hi, I have the same problem. .


#3

Anyone out there solved this problem? AFAIK it is due to cranberry cordova plugins not being updated!