Build Works Fine, But Still Getting iOS Black Screen:(


#1

Hello all… As I said, my iOS Cocoon.io build works fine, but I keep on getting the iOS black screen for some reason. Can someone please help me out? Is anyone else experiencing the same problem?


#2

I have the same problem, I guess it would be good to run the developer app, it might throw some errors, but unfortunately I can’t figure out how.


#3

Hey,
@daniel.danielecki, @sbstn
I had same problem few days back what i did is i used Canvas+ for my Webview engine and it removed the blackscreen.


#4

Worked, thanks!
Just screen of my app is cutted, need to figure out why this behaviour is on iOS…


#5

@daniel.danielecki Whats the screen resolution you have of your phone try to set the layout size accordingly or if you want it to be compatible with every screen size try to use Viewport left/right/top/bottom for your objects so it will fit every screen. let us know if it solved your problem.


#6

I can’t get my iOS build to work with webview+. Can someone please show me a fix for this?


#7

Webview + will give you error try to use canvas+


#8

Is there any way to fix the issue? Can’t use Canvas… It splits the screen in half, and doesn’t have any sound:(… Please, there must be a way to use webview+. Is Ashley going to be fixing this bug for the next Construct 2 version?


#9

Please. I need help with this.


#10

I have exactly the same problem, +1


#11

Please, can someone help us with a Webview+ fix? Or, just let us know if Ashley’s going to be fixing the bug, in the next version of Construct 2? Please, we need a fix.


#12

Bump… Please… We need help. There must be an answer/solution.


#13

Bump… Please… someone… anyone! We really need some help! I’ve been stuck on this problem for three weeks now. Common…


#14

Uhgg (how long will this go on?)!!!.. Please, there must be someone who could help us…


#15

Holy… SO NO ONE’S WILLING TO HELP!!!.. This is getting freakin ridiculous!

@andy_reitberger , Please… can you please, give me some clear explanation on what exactly is going on, and how to fix iOS Webview+ Black Screen problem?

This problem’s been persisting for months now, leaving everyone to out dry, with no direction on what to do next… What’s the point of even using cocoon anymore, as an iOS developer, if this problem can’t be fixed?

When can we expect the problem to be fixed? Or will Webview+, never work for iOS?


#16

Build with construct 2 (244) give with me no black screen, building with R257 gives black screen


#17

Okay, I’ll try that @dannyb, but the last piece of advice someone told me, was “to use construct 2 (245)”, and that didn’t work, so…


#18

Hi,
if you want to get help, you should fill out the complete report template coming along with posting in this category. Also provide as much as information as possible. Best a capx file to check.

Otherwise it’s impossible to figure out what your issue is…

Thanks!

Best,
Andy


#19

I’ll come back to this topic, unfortunately Webview+ seems to be still not working, at least for iOS, @andy_reitberger are there any chances it’ll be fixed?

@maddy467 my apologies for late answer, all my builds on Android are Webview+, all of them fills full screen, nevertheless if this is tablet or phone, here (tested on iPad Pro 9.7) I got cutted screen, see attachment. I think the problem is that it’s being compiled with Canvas+, because Webview+ compilations seems to be still not working…


#20

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.