Cannot publish IPA

I urgently need to push our completed application update to ITunes Connect today, only to find that all of a sudden I cannot push our IPA (as we normally do) as it comes back with a number of errors from a release build using production key:

  1. Missing 1024x1024 icon (warning) - the icon is definitely in the project.
  2. Missing provisioning profile (error)
  3. Warning about March 2019 compilation with SDK 12.x (can ignore this for now)
  4. Error about supported CFBundleDevice as the release package seems to include a CDVDebugService bundle which includes iphonesimulator

This is super urgent and any help would be appreciated!

PS, This was tried with 2.2.0, I have now tried 3-beta as I know it was working fine with our development builds, but it seems it now won’t compile with 3 possibly due to the production signing key.

After following another suggestion to manually edit the xcarchive file generated when building without a key I can remove the above debug / iphonesimulator related issue however the others remain. I was able to create an ipa file from this to submit to the store, however when i get it there now all of a sudden it seems to think I am using IDFA. I do not have any plugins related to advertising in any way shape or form so I can still not publish the build.

May I know how did you managed to edit the infoplist? I have the same cfbundlesupportedplatform issue as well. Thanks!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.