CanvasPlus BlackScreen


Hi all,

Latelly with some games from C2 I obtain blackscreen using canvas+ with Webview+ game works but performace is worse.

Is there a way to solve this issue?



Hi @touxstudio

please fill out the bug report template if you post an issue. Also provide a testcase.
Thank you!



I was having the same problem as you. After a topic from the C2 group here from my country, it seems like things are back to normal. Try the following options:

On C2, In “Configurations Settings”

  • Leaves the “Enable Webgl” option in “Off”

  • In “loader style” leave “progress bar and logo”

When export the project: Do not check* the option “minify script”

Before compiling no cocoon:

In “Setting”:

  • “Cocoon Version”: Select “2.0.0”

  • “Webview engine”: “Canvas+”

In “Splashscreen”

  • “Scale Mode”: “Aspect Fill”

Try these settings.

Waiting for feedback


Do not set WebGL off and set “percentage text only” for loader bar.
Can you try with this settings?



Hi @andy_reitberger , I tried your way but no luck. BlackScreen


I also tried your way and worked but with very very big resolution, unplayable.

Any other idea how to fix this issue?

Greetens and thank both.



Alright so I have been getting that “Black screen” after Cocoon splash too, lately, despite having the same worked a few weeks ago. So something changed at Cocoon’s end, that is causing the problem.

Here is how I fixed, thanks to @wesleytonaarea2013 for the idea.

Simply change the Default cocoon version to: 2.0.0, and use Canvas+. (Don’t change the Splash settings please).

In C2: I am using: “Percentage text” as Loader Style, WebGL = on, Manify script = untick

@touxstudio Try it out, let us know.

@andy_reitberger Can you please confirm if nothing has changed at cocoon’s end. A lot of ppl are getting this black screen lately, using simple C2 projects without plugins, compiled using Canvas+ with latest cocoon. Thanks


@m.hasan.shariq The problem seems to be in the cocoon build version. But even before this option was checked it was not working.


I’m not aware of any changes. Also all my games are working like before. None of them throws any errors resulting in a black screen.
Have you checked this post already?

This is how I configure my projects. Never had any blackscreen.



Hello, @andy_reitberger .

Yes, same config I tried everything.

Percentage TExt, Enable on, everything. Last or two week I’ve compiled same app on your platform and using Canvas+ with positive result. Why not now?

I also tried 2.0 Canvas+ but resolution was not expected. I can see only a 10% of the game. Like a very big zoom.

Last month I bought one year subscription, but I have same issue with last two games I tried. Atm using XDK I solved the problem, but as you know this month is the last for this proyect. I need an alternative.

It works using cordova and XDK.

So as another member said, the prob is on your updates or something.




It’s hard to say what the issue is on your end without having a test case.
Can you provide a minimalistic capx example where this issue comes up?

Also, if you export from C2, have you checked “Minify Script”? If so, uncheck it.
Moreover be sure that you had deleted the “config.xml” file coming from the C2 export before you uploaded the zip file to cocoon.

I just build a game made with C2 and it works on my end, so it has nothing to do with the compiler itself.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.