Cocoon 2.2.0 - V8 Update is here!


#21

i know gamepad is in the doc, but it is not working any more


#22

Thank you for the update!

Cocoon is seriously falling behind in terms of canvas features, which should be a main priority for a tool like this. Can we expect a Canvas+ feature update this year?


#23

Alright & tnx for the info. Any rough ETA? Days, weeks or a month away? :slight_smile:


#24

https://www.scirra.com/manual/109/audio

Advanced audio
The Audio object supports some advanced features, such as positioned sounds and convolution effects. However these depend on the Web Audio API which is not supported in all browsers. You can detect if these features are available using the Advanced audio supported condition. If it is not supported, the advanced audio features will not change the sound in any way.

Oh, it is Web Audio feature? Canvas+ still don’t support : (


#25

It does work with Cocoon 2.1.0 so I rather think it’s an issue in 2.2.0.

Regards
Andy


#26

@andy_reitberger
Nope, I tried Cocoon 2.1.0 + Canvas+
Still didn’t support.

Also I tried with Cocoon 2.2.0 + Webview+
It is not working fine. I think not support.

@Blue_Sialia
Another issue with Cocoon Developer App
if I open my game with Webview+ FullScreen not work. I mean I see only yellow area in my phone.
But if I use Webview+ Debug.apk, FullScreen working. I mean I see blue area.
Game Area
My Settings


#27

I meant that the sound is working in 2.1.0, and it doesn’t do in 2.2.0.
That’s an issue with 2.2.0

Regards
Andy


#28

We are trying to finish testing next week. But new iOS SDKs usually change things about signing that are a pain to deal with.


#29

Canvas+ does not support Web Audio, so it makes sense those Advanced Audio Features don’t work. It should work with Webview+ though :thinking:

Will investigate the DevApp issue.


#30

Will investigate the DevApp issue.

Thx for this.

Also I don’t want use Webview+
Anyways, I will try simulate Advanced Audio Features.
Every tick | set value = random(0,15) should work for my game.


#31

Exact! the sound stops playing mysteriously after a while of playing.
Thanks for the data, I’m going to change to 2.1.0! Thank you!


#32

also ,i can’t see plugins installed. it give me a blanc screen i must go xml settings and remove them manually


#33

Does anyone know if building a construct 2 game and importing to cocoon still work? I keep getting compile issues.


#34

it still working see in installed plugins if you see a plugin called “config”. and just delete it.


#35

Hi,
It does work for me. What issue do you get?
Please open a topic in the “Troubleshooting” category and fillout the but report template.

Thanks!


#36

"Operation failed

Reason: The requested compilation does not have platforms enabled."

This keeps popping up every time I upload my zip folder the cocoon and hit compile.


#37

Any news on the iOS11 SDK? :slight_smile:


#38

Any chance the C2 sound issue will get resolved any time soon? It’s been over a month…

Its not working on any version of Cocoon for me. I’ve had it work fine in the past