Cocoon Ads with Onesignal crashes the build


I am trying to Use cocoon Ads(Android) and onesignal plugin ( but it crashes. Either i have to use onsignal or the ad plugin.

Is there any way to fix it.?


Try other one if you can.


Hey I tried all the onesignal plugins but nothing seems to work… Like few works and make the build successful but I don’t recieve the notification… So I have to get that plugin or the onesignal Cordova 2.41 plugin but those crashes and not only with cocoon ads but with every ad plugins.


I use Admobpro Plugins. It’s working pretty fine for me.


Can you share the admobpro plugin link please?
I have tried everything till now but it seems to be crashing
Did you get the notification also.?


you use construct 2 right?
if yes here :
in not (probably) here :


Yes I do use Construct 2. Let me try this one and i’ll get back to you thanks for the help


Hey i tried building the app again and this time I used your plugin.

Admob pro plugin: cordova-plugin-admobpro(Build Crashed)
Admob pro firebase: cordova-plugin-admobpro-firebase( Works but doesn’t show any ads)
Onesignal Plugin: onesignal-cordova-plugin


Did you put in the ads unit code?
You install the plugins again in the plugins in the cocoon menu right?
You use the the plugins that lable as “admobpro” in the cocoon plugins menu right?
If all of this isn’t the thing that you did, it might not work. But if yes It work for me


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.