Cocoon Ads working in Constrcut 2


#1

Old Cocoon Ads plugin

:small_blue_diamond:Hello to all I recommend you use the old cocoon plugin because it is working … use the 2.2.0 version of cocoon or 2.1.0 copy the plugin version here. :small_blue_diamond:

<plugin name=“cocoon-plugin-ads-android-admob” spec=“1.0.12” /> :soon: this should be copied to the config.xml file.

let me know if it works for you I hope to have been helpful! :grinning:

:floppy_disk:Cocoon_Plugin_old.zip (7.7 KB)


#2

remember that this plugin is only for users who use construct 2


#3

Hmm tha’ts why I cant see ads I’m using phaser


#4

I am using Phaser and ads work, even rewarded videos. I am using Cocoon 2.2.0 and this is in config.xml file: <plugin name="cocoon-plugin-ads-android-admob" spec="^1.0.0"/>


#5

Right you will be able to compile app like this however by using old version of cocoon your targetSDK version will be 23 and Google will not allow to publish such apps.


#6

There is a workaround that works, using this line in config.xml:
<preference name="android-targetSdkVersion" value="26"/>


#7

Did you succeed by publishing app just by setting targetSDK to 26 ?
I have tried like that but google shows message that apk API level is lower than 26.


#8

Yes, app is published on Google play store.


#9

this is for construct 2 I do not know for phaser what should be done …


#10

I put the sdk 26 in the config.xml file


#11

Oh I used 1.0.12, Thanks @jsmekal I’ll use that plugin version


#12

Not work i have a problem with this tutorial


#13

what is your problem?


#14

I have tried to set target SDK to 26 and app is compiling however google still not allowing to publish app and states that app is using 25 version of SDK


#15

did you use this method? I read that it works
<preference name=“android-targetSdkVersion” value=“26”/>


#16

webview+ have a problem,loooooooooool


#17

try using Canvas + and change the plugin version from 1.0.0 to 1.0.12


#18

Pleas find attached screenshot of my config.xml