Cocoon GooglePlayGames Login Trigger Problem

  • Cocoon Version:

  • Basic description of the problem:
    GooglePlayGames Login Triggering in Cocoonsplash Screen. There is no eventsheet it is Cocoon’s Splash screen.

  • Device info:
    NoxApp Android Emulator (Android 5.1)

  • Steps will reproduce the problem:
    1.) I add Login Action for GooglePlayGames
    2.) Action running only when it is in Game Layout.
    3.) But it is triggering two times. (CocoonSplash and Game Layout)

  • Expected result:
    Trigger login one time when go to Game Layout.

  • Error log
    No Error.

  • Webview engine(s):
    Developer App (Canvas+)

  • Used plugins (if relevant):
    Cocoon GooglePlayGames

  • Framework/game engine (if relevant):
    Construct 2

About New Cocoon Update

Did you upload the APK to google playstore first.? Because i had the same issue and i solved that by uploading it to the playstore its basically google links your app to google play service and enables the features to your app ID


I did already, signed apk and I add test users.
Just it is happening sometimes. How it is happening in cocoon splash screen, still i don’t understand.


This is what my codes are and they work good


@OhhBaby I am also having the same Issue. Not able to login through googleplaygame or gamecenter.
@maddy467 I followed your events but that doesn’t work.


Please Help us. @andy_reitberger @Blue_Sialia


but this is works very well to me


Your problem not looks like this.
You need add test users in Googleplay console.


the Google Play and GameCenter plugins are working well.
Either it’s a wrong code or a miss-configuration.

I can recommend you my template for Game Center and Google Play.

A documentation can be found here.



It is working but I still wondering how this happening? I didn’t tell not work just have this problem, sametimes when I do build apk I see this trigger problem.
"GooglePlayGames Login Triggering in Cocoonsplash Screen."


Thank you for the reply but the plugins were working just perfect in the last build and in new i just replaced few images and boom they are not working any more. I tested google play and game center both were awesome before but after rebuilding the new app they just can’t login and i have not touched any coding.


Hello guys thanks for all your help. Turns out that my firebase was not linked properly so I got it solved by linking the firebase and rechecking the ID’s and matching them


Have you any “Login” actions in your loader event sheet or in your first event sheet which gets called on game start?
As long as you do not call the “Login” action it should not login automatically.
You can try to just add the Google Play Games plugin to an empty project and build it. If it logs in even without any code, then there is a problem in the plugin code itself.

Can you try this?


I said before it is happening sometimes.
I have login action only in “Game_Layout”'s event sheet. Also I add this;
System | LayoutName=‘Game_Layout’ so this mean it must run only in Game_Layout


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.