Compilation error when using GameAnalitycs plugin {Construct2}


#1

Error when compiling with GameAnalitycs plugin:
HELP
COMPILER ERROR:

/workspace/platforms/android/gradlew: Command failed with exit code 1 Error output:
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /workspace/platforms/android/src/org/crosswalk/engine/XWalkCordovaResourceClient.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:transformClassesWithDexForArmv7Release’.

com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.dex.DexException: Multiple dex files define Lcom/google/android/gms/internal/zzew;

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 1 mins 44.605 secs

Thanks


#2

Hi,
the GA plugin for Construct is for HTML5 games. It will not work in a cordova built.
GA needs to make a cordova plugin as counterpart first.

Best,
Andy


#3

It is working with Phonegap. Just only error with Cocoon.


#4

hyh
can You fix it?
this is popular plugin for C2 and it’s for mobile games: