Compile ERROR still


#1

Hello, i have big problems :((

COMPILER ERROR:

/workspace/platforms/android/gradlew: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • Where:
    Script ‘/workspace/platforms/android/cordova-plugin-crosswalk-webview/CyaFlex-xwalk.gradle’ line: 161

  • What went wrong:
    A problem occurred evaluating root project ‘android’.

Could not find method implementation() for arguments [org.xwalk:xwalk_core_library:23+] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

CORDOVA LOG:

e[36m20180830T214805 [DEBUG] AndroidBuilder -e[39m [prepare] cordova restore platforms
e[36m20180830T214805 [DEBUG] AndroidBuilder -e[39m [prepare] adding engine android@6.2.3
Subproject Path: CordovaLib
Subproject Path: CordovaLib
Subproject Path: CordovaLib
(node:24434) [DEP0016] DeprecationWarning: ‘root’ is deprecated, use ‘global’
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] cordova restore plugins
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin com.ludei.defaultres.android@1.0.1
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin com.ludei.installlocation.android@1.0.0
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin com.ludei.usericon.android@1.0.1
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin com.ludei.webviewplus.android@2.2.1
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin com.ludei.webviewplus.ios@1.1.4
e[36m20180830T214827 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin cordova-plugin-whitelist@1
e[36m20180830T214829 [DEBUG] AndroidBuilder -e[39m [build]
Warning: File /.android/repositories.cfg could not be loaded.
e[36m20180830T214830 [DEBUG] AndroidBuilder -e[39m [build] call cordova
ANDROID_HOME=/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux
JAVA_HOME=/usr/lib/jvm/default-java
Subproject Path: CordovaLib
null
The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.
at build_b79tyigzb5xd7bdkgoodq4kby.run(/workspace/platforms/android/build.gradle:139)
org.xwalk:xwalk_core_library:23+

FAILURE: Build failed with an exception.

  • Where:
    Script ‘/workspace/platforms/android/cordova-plugin-crosswalk-webview/CyaFlex-xwalk.gradle’ line: 161

  • What went wrong:
    A problem occurred evaluating root project ‘android’.

Could not find method implementation() for arguments [org.xwalk:xwalk_core_library:23+] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 0.932 secs
e[91m20180830T214835 [ERROR] AndroidBuilder -e[39m { Error: /workspace/platforms/android/gradlew: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • Where:
    Script ‘/workspace/platforms/android/cordova-plugin-crosswalk-webview/CyaFlex-xwalk.gradle’ line: 161

  • What went wrong:
    A problem occurred evaluating root project ‘android’.

Could not find method implementation() for arguments [org.xwalk:xwalk_core_library:23+] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    at ChildProcess.whenDone (/workspace/platforms/android/cordova/node_modules/cordova-common/src/superspawn.js:169:23)
    at ChildProcess.emit (events.js:182:13)
    at maybeClose (internal/child_process.js:961:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:248:5)
    stderr:
    ‘\nFAILURE: Build failed with an exception.\n\n* Where:\nScript ‘/workspace/platforms/android/cordova-plugin-crosswalk-webview/CyaFlex-xwalk.gradle’ line: 161\n\n* What went wrong:\nA problem occurred evaluating root project ‘android’.\n> Could not find method implementation() for arguments [org.xwalk:xwalk_core_library:23+] on object of type org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.\n\n* Try:\nRun with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.\n’,
    stdout:
    ‘null\nThe Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.\n\tat build_b79tyigzb5xd7bdkgoodq4kby.run(/workspace/platforms/android/build.gradle:139)\norg.xwalk:xwalk_core_library:23+\n\nBUILD FAILED\n\nTotal time: 0.932 secs\n’,
    code: 1 }

#2

Same here…!! So Frustrating, I need to update my game urgently, and I can’t !

I have some serious questions:

  1. Why isn’t Cocoon team getting back on this? even an expected fix date would help!

  2. Why did Cocoon dev team decide to ruin the existing Cocoon version’s process, shouldn’t this test phase be happening in the background and/or in 3.0.0 Beta ONLY? Why can’t I use the previous version 2.2.0 and publish with the previous API Level normally?

@Blue_Sialia Hoping you would at least respond? Thank you!


#3

Indeed everybody that already has an app into production is in dire need of at least an update. I think you touch the main issue: the lack of any response of the Cocoon Team. Being in the dark is the worst part, as we have to constantly do damage control with our player-bases while unable to give them any updates on when we will be able to deliver a fixed build :confused:

I have been able to compile a 3.0.0 build successfully somehow, but it does not work on certain devices (Samsung Galaxy S8 specifically has issues with a Black Screen showing Up).