Compiler Doing Black Screen After Splash


Thank you all for trying to figure this out. I really, really appreciate your help. Thank you :smile:


Here you can download a sample capx file which is working for me.

Let me know if this still causes a black screen on your end.



Sorry i got really busy. It does still do a black screen sorry :frowning:


Yea, I tried everything in that help thing, and it’s still not working. I think Cocoon IO is broken cause it’s not working.


It’s working fine for me, so it must be project relevant.
That’s the only thing what I can say at the moment.



If it were the Project then why does a project that worked before not work now? It can’t be the Project. Then please explain why code that worked before, without being modified at all whatsoever, doesn’t work now. Something that before this happened. I didn’t change ANYTHING. This the file that I restored, and did not modify. It used to work, and now it doesn’t.

Please explain that. The code is exactly the same. It worked before, and now it doesn’t. So it cannot be the Project. Because if it were the Project, the one that was working would still be working, would it not?


Explain that. It’s the same Version of Construct 2. Same exact version no difference. Why would code that worked before, the same exact code that worked before, not work now?


@andy_reitberger , can you also try compiling some of their www project files… Because, as I presume, you always delete the config file and hence use the previous config of cocoon (which would work fine), but the new config created with the newer versions of C2 may be the cause of the problem for many.

Now they cannot possibly delete the config and make things work, that won’t work anymore, since a non-functioning config is saved at Cocoon.

Please review. Thanks


enable web gl to on in construct this solve problem to use cocoon 2.1. Or just trade cocoon to 2.0 (only cocoon 2.0 work with web gl off) cocoon 2.1 need web gl on


Warn others who are complaining about the black screen, which has two options to correct, if you use cocoon 2.1 it is necessary that in the construct the web gl is enabled. If it is in the version of cocoon 2.0 the gl web was giving to get off. These are two methods of solving the black screen problem. Spread the news that the problem is the web gl disabled in the version of cocoon 2.1


you always need to delete the config.xml file.
Otherwise the cocoon config.xml file will be overwritten which can lead to a blackscreen.

Try to make a new project, delete the config.xml file coming from c2, zip the files and upload it (as new project).
See if it works then.
This is the way I do it and it’s working fine on my end.



This is mentioned in my Troubleshooting page.

It’s always recommended to use WebGL, otherwise it can lead to scaling issues and / or black screens.
I never have turned it off, and I never have had any blackscreens (no matter what cocoon version I’ve used).



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.