COMPILER ERROR: Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1"


#1
  • Cocoon Version: latest

config.xml

plugin name=“cocoon-plugin-ads-android-heyzap” spec="*"
plugin name=“cocoon-plugin-ads-android-heyzap-adcolony” spec="*"
plugin name=“cocoon-plugin-ads-android-heyzap-unityads” spec="*"

Cocoon does not compile apk and show error:

COMPILER ERROR: 

Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1". Try --force to use installed plugin as dependency.

CORDOVA LOG: 

e[36m20180904T112343 [DEBUG] AndroidBuilder -e[39m [prepare] cordova restore platforms
e[36m20180904T112343 [DEBUG] AndroidBuilder -e[39m [prepare] adding engine android@7.1.1
e[36m20180904T112417 [DEBUG] AndroidBuilder -e[39m [prepare] cordova restore plugins
e[36m20180904T112417 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin cordova-plugin-google-analytics-fork@*
e[36m20180904T112417 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin cocoon-plugin-ads-android-heyzap@*
e[36m20180904T112417 [DEBUG] AndroidBuilder -e[39m [prepare] adding plugin cocoon-plugin-ads-android-heyzap-adcolony@*
e[91m20180904T112417 [ERROR] AndroidBuilder -e[39m { CordovaError: Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1". Try --force to use installed plugin as dependency.
    at /opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/cordova-lib/src/plugman/install.js:557:37
    at _fulfilled (/opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/q/q.js:787:54)
    at /opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/q/q.js:816:30
    at Promise.promise.promiseDispatch (/opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/q/q.js:749:13)
    at /opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/q/q.js:509:49
    at flush (/opt/cocoon_compiler/workspace/production/data/libs/cordova-lib@8.0.0/node_modules/q/q.js:108:17)
    at process._tickCallback (internal/process/next_tick.js:61:11)
  name: 'CordovaError',
  message:
   'Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1". Try --force to use installed plugin as dependency.',
  code: 0,
  context: undefined }
e[91m20180904T112417 [ERROR] AndroidBuilder -e[39m BuilderError {
  message:
   'Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1". Try --force to use installed plugin as dependency.',
  msgPublic:
   'Version of installed plugin: "cocoon-plugin-ads-ios-heyzap@1.1.0" does not satisfy dependency plugin requirement "cocoon-plugin-ads-ios-heyzap@^1.1.1". Try --force to use installed plugin as dependency.' }

I do not use plugin “cocoon-plugin-ads-ios-heyzap”.
Why do I see this error?
Where can I get this version plugin “cocoon-plugin-ads-ios-heyzap@^1.1.1”?
There is only version 1.1.0 (https://www.npmjs.com/package/cocoon-plugin-ads-ios-heyzap)

This problem I start see only August-September 2018.


#2

I changed ‘config.xml’ (must set right version) and it help me:

<plugin name="cocoon-plugin-ads-ios-heyzap" spec="*"/>
<plugin name="cocoon-plugin-ads-ios-heyzap-adcolony" spec="*"/>
<plugin name="cocoon-plugin-ads-ios-heyzap-unityads" spec="*"/>
<plugin name="cocoon-plugin-ads-android-heyzap" spec="*"/>
<plugin name="cocoon-plugin-ads-android-heyzap-adcolony" spec="1.1.0"/>
<plugin name="cocoon-plugin-ads-android-heyzap-unityads" spec="1.1.0"/>