Compiler not working


#1

The compiler gives the same error for both our project, for old and new zip files alike. Even zip files that compiled previously and have not been re-uploaded give this error, so it has to be on your side. We’re busy with an important release, so it’s extremely important that we can compile our project as soon as possible.

COMPILER ERROR: 

Error extracting the zip contents. Check that your zip file is valid and filenames does not contain foreign characters

CORDOVA LOG: 

No log available

#2

Hello, we had the exact issue, in our case we have made zip on OS X. If that is the same for you, just make zip file on Windows if it is possible.


#3

Hey baneroks! Thank you for the reply!

No, we make our zips on Windows and we always have. Even zip files that compiled last time we tried, suddenly don’t work anymore. Hence why we know the the problem has to be on Cocoon’s side. One of our projects which used to compile, to which we haven’t uploaded a new zip, now doesn’t compile. In other words: Cocoon is bugged atm. At the very least for our account / projects.


#4

It’s been 16 hours with no reply from Ludei here or via email and the compiler still doesn’t work. Our app is bugged now because the web version and app are out of sync, causing server side issues. We’re desperate for help here, but we don’t know any direct ways to approach someone from Ludei…

Any help from anyone in this regards?


#5

Ludei always had slow support on the forums - if there was support at all, Not sure, but maybe the email support that you buy with the gold license work better? It might be an option if you are desperate.

On the issue: I have no problems with uploading and compiling my projects at the moment. So it’s not a global issue. You could try different tools for packing or recreating the project or similar - if you didn’t do so yet.


#6

@mk1 Thank you. That is at least confirmation that something is wrong with our account / projects. Still, we didn’t change a thing. All zips are created the old-fashioned standard way via Windows. We’re gonna do our best to track down the source of this issue ourselves. Unfortunately, no response from Ludei via email, form or Facebook.


#7

After some testing we have found the source of the error. Zip files created through Window’s native zip functionality no longer work for Cocoon and produce the error. Zip files created through 7-zip do work as normal.

It is important to note that zip files created by Windows have always worked for Cocoon. Even files that we already uploaded and compiled months ago, now no longer work, without us having uploaded anything new. So something changed in Cocoon that causes this error. I hope it will be fixed, but in the meantime we have our workaround and can finally continue the release of our patch.

Zero points for support.


#8

I am also having the same issue using PHP’s gzcompress on Windows. I have an automated script and don’t want to manually have to use 7-zip to build my bundle. Please fix this Ludei.


#9

7zip also works from the command line, no need to manually use it.


Can't compile any project!
#10

True, but this is a bug nevertheless. Backwards compatibility should not be broken like this.


#11

Thought I’d note that WinRAR zips also work


#12

Of course that’s a bug and should get fixed asap. But looking at how Cocoon developers didn’t talk on the forum for roughly two months and how “fast” bugs usually get fixed I wouldn’t expect a fix for the issue anytime soon.

Andy Reitberger has the cocoon logo on his profile and is active and very helpfull but the title (“Advocat”) doesn’t sound like he’s working for Ludei. So it’s unclear if Ludei even knows about this bug.

I’d go with 7zip automation for now, you can always switch back in case Ludei fixes this.


Please help! urgent!
#13

Yes you are right. I’m not a member of ludei. I’m just helping them out with their support. So that the devs can focus on fixing the issues in the compiler.
I got respone from a ludei member. At the moment they focus on mail support requests (for gold members).
Hopefully they will come back soon.

Regards
Andy


#14

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.