[Construct 2] Black Screen


#1

I exported my game into Cordova, compile it success, then, when i opened my game, showed cocoon logo, after logo - nothing, only black screen…
Project plugins: http://dl1.joxi.net/drive/0008/0341/561493/150721/75b2cb5d59.png
Project settings: http://dl1.joxi.net/drive/0008/0341/561493/150721/3322c124fe.png
Config file: http://dl1.joxi.net/drive/0008/0341/561493/150721/9ab94df925.png
Cocoon plugins in Construct 2: http://dl1.joxi.net/drive/0008/0341/561493/150721/dfbf12ec8a.png
Construct 2 properties: http://dl2.joxi.net/drive/0008/0341/561493/150722/1b37ede4ec.png
Any plugins in Construct 2: http://dl2.joxi.net/drive/0008/0341/561493/150722/3a638ecd4b.png
I tried to compile empty project… and too black screen…


#2

Hello,

First of all, you provided so much information but I still need to ask you for the device log.

Secondly, the config xml is not generated by the cloud, because I can see the “gap” label in some options. I recommend you to configure the project directly at the cloud.

Third, are you using physics? If so, you are using the wrong library in C2, please, pick Box2D web.

In addition, I can’t tell just by a picture if the Audio, Keyboard and the rest of features you mention are compatible with Canvas+.

Canvas+ is for canvas based games. Again, I must insist on asking you for the log.

Even if the project is empty, if you have plugins or objects that are not supported, the result will be the same. The blanck screen means there is an error somewhere. And for sure it will be reported in the log.


#3

What log do you mean?


#4

I select Box2Dweb, the black screen disappears (Physics does not using in menu), when i start my first level (Go from menu into game level with physics objects) black screen appears again!


#5

This log:

http://developer.android.com/tools/help/logcat.html

Please, compile a developer app to debug the error.


#6

Also standard Splash screen C2 conflicts with splash screen Cocoon.IO and a black screen appears.


#7

I have not splash screen


#8

То что у тебя нету я в курсе. Я для других пишу, которые потом будут эту тему читать.


#9

What do you mean? We didn’t have such an issue in our tests. Did you delete the config.xml file as we suggested in the tutorials?

Please, if you want us to be able to help you, write in English. Otherwise, it will be impossible.

Regards


#10

Thank you for attention. At the moment, I have no problem with your service. Everything works fine and performance pleases.


#11

All okey, i set box2d web and black screen dissappear, but in ALL games in layouts with physics objects the black screen again appears


#12

As I said, please, provide a log and a test case :slight_smile:


#13

How i do it? In signed apk (not developer app) app loading successful, but when i compile developer app there are agaion black screen


#14

So… is the problem solved? Is the game working after compilation?


#15

Work only layout without physics objects in compiled game
Compiled developer app game doesn’t work


#16

Send us a link from google drive or dropbox for the test case.

The log, if we are talking about android, you need to use the “adb logcat” command: http://developer.android.com/tools/help/logcat.html

You can paste the result directly here.

Regards


#17

Sorry, i don;t understand how do it :confused:, could you write how do it step by step?


#18

Same happens on my end. Once the layout with the physic objects comes up, it crashs and stops working.
I use

  • Construct 2 r210 beta
  • Box2Dweb
  • Canvas+

This is the error I get in the developer app.

JavaScript Exception (Tag: 'requestAnimationFrame'): TypeError: undefined is not a function
at new Box2D.Dynamics.b2FixtureDef (c2runtime.js:25938:16)
at behinstProto.createBody (c2runtime.js:31868:16)
at behinstProto.tick (c2runtime.js:32103:9)
at Runtime.logic (c2runtime.js:5115:29)
at Runtime.tick (c2runtime.js:5016:8)
at tickFunc (c2runtime.js:3846:47)

The runtime file:
I tried to upload it but I guess the uploader just accepts images, so just check my Project “ZombieAttack”. There you can see the c2runtime.js file for further information.


Construct 2 Compilations not working
#19

We will have a look at it. Thank you for the test case.

Regards


#20

Any news on this? I have the exact same problem, Construct2 r210, box2d.web