[Construct2] data.js not found on ipad IOS 10.3.3


Cocoon version = Latest
Cordova ios v4.3.0

I’ve compiled and submitted my IPA to App Store for review, on two occasions now they have flagged the app for a bug, which is odd because when I test it, is working fine in simulator.

The specific testing environment is

“We discovered one or more bugs in your app when reviewed on iPhone and iPad running iOS 10.3.3 on Wi-Fi connected to an IPv6 network.”

The first time I submitted the IPA it was only on an iPad device this bug was found, but the second time around it is now iPhone and iPad.

The specific bug is that the app fails to start because data.js is not found. data.js is specifically the entire gama data in Construct2, is there some issue using webview+ on this version of ios?


I just have submitted an app to Apple using Canvas+.
I let you know if mine gets rejected with the same error. While testing all was fine on my Iphone and iPad.



Yeh Im going to try canvas+ the only thing putting me off it was the ridiculous $500 de-branding fee


I still recommend you to use CanvasPlus because WebViewPlus has issues with the LocalStorage. Data gets lost whenever the game is closed.



Any docs on this issue? looking at the construct runtime looks like data.js is loaded via a cordova function fetchLocalFileViaCordovaAsText

	self.fetchLocalFileViaCordovaAsText("data.js", function (str)
				alert("Error fetching data.js");

wonder if there is a compatibility issue with this web view and this function?


Does it work with Canvas on your end?
My game just got approved by Apple and it’s online.

I haven’t tried WebView due to the LocalStorage issue. Haven’t you had any issues with it? Or don’t you use LocalStorage?



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.