CordovaLocalWebServer: tag src is not http://localhost[:port] (is http://www.###.com)


#1

I have a web2app project I created with a url from my site. I have noticed that whenever I try to add an icon and a splash screen, I get the error below:

CordovaLocalWebServer: tag src is not http://localhost[:port] (is http://www.###.com)

Everything only works when I remove splash screen images and icon images. I was planning to upgrade my membership but I can’t do that until at least such a bug is fixed.


[Duplicated] IOS Webview+ error
#2

I would really like to know why this happens, I have a presentation tomorrow and would have loved to have the app icons and splash screens before then.


#3

no responses, I can’t use web 2 app then :frowning:


#4

Hi @saibotlive,

I can’t reproduce the error. Please, could you tell me what iOS device and iOS version are you using?

Regards.


#5

Hi, I am using an iPhone 6 with IOS 9.2.1 . Everything works fine if I don’t have an icon or splash image but when I include them, I get the error above.


#6

I have tried this with different server urls and still the same thing.


#7

I have just tried compiling my web2app project again and it works fine without icon and splash but still gets this error below when I re-add icon and splash images. I have tested on my iPhone and iPad, both latest versions.


#8

I spent the weekend trying this on different IOS devices and versions and it’s alwyas the same error like the screenshot as soon as I have an icon and splash screen. This just means Web2Ap is not a finished product at all.


#9

After testing on Android with Samsung Galaxy S5, I get this message below on first load. But if I go back to reopen the app the 2nd time, it then works. I chose cocoon as I felt it would be a smoother experience in building for both IOS and Android but I feel I am not even getting the help I need.


#10

I am seriously considering cancelling my membership. I upgraded my account because I felt Web2app is exactly what I needed but there’s no point if I can only use it without icon and splash screen.


#11

I finally found the problem.

The issue is from Cordova, we aren’t using the last version of it.

We have a testing environment to… well… test things. I couldn’t reproduce the error because be just updated Cordova in the testing environment and it works fine there.

We are going to release a new version of the Cocoon compilers, with the updated Cordova, in the next few days (we will send an email to notify). It should fix your problem.

Regards.


#12

Thanks @Blue_Sialia, looking forward to the updated version :relaxed:


#13

Hi.

Can you confirm if the new version of the Cocoon compilers (with the updated Cordova) has been released?

We are seeing the same issue with webview+ app; it only works if we don’t supply custom icon/splash.

Thank you.


#14

Hi,

This problem has been fixed and the fix is available in the cloud service. Let us know if you find any other issue.


#15

Looks like the problem is occurring again.

Same error message, but it’s default (index.html) instead. From a C2 export.


#16

Same problem here :frowning:
Binary rejected because of this issue.
Any update about this? Or workaround?
Thanks!