Could not find com.google.android.gms:play-services-ads:15.0.1

  • Cocoon Version:
    What Cocoon version are you using to compile (i.e. 1.0.0)?

  • Basic description of the problem:
    Describe the issue

  • Device info:
    Model, OS version…

  • Steps will reproduce the problem:

  1. First step
  2. Second step
  • Expected result:
    What’s the expected result?

  • Error log
    Relevant error log. Or you can attach the log file if it’s too big

  • Testcase:
    Attach a compressed test case to reproduce the issue

  • Other information:
    Any other information that you feel is relevant

  • Webview engine(s):
    Webview engine that you are using

  • Used plugins (if relevant):
    Any relevant plugins that you are using

  • Framework/game engine (if relevant):
    The Framework that you are using

Compile Error
COMPILER ERROR:

/workspace/platforms/android/gradlew: Command failed with exit code 1 Error output:
FAILURE: Build failed with an exception.

  • What went wrong:
    A problem occurred configuring root project ‘android’.

Could not resolve all dependencies for configuration ‘:_armv7DebugApkCopy’.
Could not find com.google.android.gms:play-services-ads:15.0.1.
Searched in the following locations:
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/google/m2repository/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.jar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.jar
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.pom
file:/opt/cocoon_compiler/workspace/production/data/sdks/android-sdks-linux/extras/android/m2repository/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.jar
file:/workspace/platforms/android/sdk-manager/com/google/android/gms/play-services-ads/15.0.1/play-services-ads-15.0.1.jar
Required by:
project :

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
3 Likes

I am facing same issue. Did you solve it yet?

1 Like

No. I even tried to compile a new project and had problems with it either. I think Cocoon is having issues

1 Like

Try MultiDex enabled to true … if that doesn’t work as well, set minimum sdk to 21…

Tried both not working for me either and no reply on the cocoon devs themselves on if there is a fix or not… Hopefully nothing to serious as I use cocoon for compiling most of my apps

2 Likes

I also have the same problem may be due to plugins?

Yeah I removed the plugins and compiled successfully. Though I’m using cocoon admob plugin but when it is installed it is looking for playservices

This plugin has no play-servies-ads This is the one causing an error.

now I also work with plugins but I have another problem when I try the app on the phone tells me it is not compatible … I think it is due to the fact that cocoon arrives up to sdd 23 while my phone is android 7.0

But when you remove this plugin, the ads won’t work, right?

no they do not work without the plugin…now I’m having a problem that the app does not start after the splash
+

Any updates on the fix?

I have find the same trouble , admob is fuc… it all!
throubl

Hi @andy_reitberger

Could you please update us on this issue? Do you any date when this will be fixed?

Thanks!

Yo solved the problem. On default settings I choose cocoon version 2.2.0 then in config.xml replace I replace asterisk with 1.0.12

before with error -> plugin name=“cocoon-plugin-ads-android-admob” spec="*"/
afer no error -> plugin name=“cocoon-plugin-ads-android-admob” spec=“1.0.12”/

You just have to read their sticky post in the forum above

1 Like

You can do the same with the other plugins as well just downgrade and compile with cocoon 2.2.0 for now until we hear from a fix. Not sure what cocoon is doing right now as there has been no word from them

hey broooo… you solved the problem of the centuryoooo wow !! I appreciate it a lot!!!

Hi,
for now, you only can bypass it.

Once I know more, I’ll let you know. Please do all new posts related to this topic in the linked topic above.
I’ll close this topic to keep it clear.

Thanks!