GameCenter stopped working


#1
  • Cocoon Version:
    2.0.0

  • Basic description of the problem:
    I cannot login / logout to the Game Center in my recents built. The code haven’t been changed and if I download a previous version, the leaderboard works (but also no logout is possible).

  • Device info:
    Iphone 5S, IPad Air 2, iOS 10

  • Steps will reproduce the problem:

  1. Download the game https://itunes.apple.com/de/app/match3-2048/id1111204649?mt=8
  2. Click on “Leaderboards” and then on either Achievements or the leaderboard icon. There is not even a login message shown.
  • Expected result:
    Leaderboard logins in and gives the player access to the achievements and leaderboard. On my previous version it worked fine and I made no changes to it.

  • Error log
    No error log in the Developer App shown.

  • Testcase:
    Via PM if needed

  • Other information:
    None

  • Webview engine(s):
    Canvas+

  • Used plugins (if relevant):
    GameCenter
    Google Play Games
    AdMob
    InApp

Core:
File

Additional
WKWebvie+
httpd

  • Framework/game engine (if relevant):
    Construct 2

Game Center (Construct 2) not worked! no login!
How to turn a Game Center (iOS) on Construct 2
Anyone have iOS Leaderboards & Achievements working?
[Construct2] Game Center doesn't work!
#2

@Blue_Sialia any news on this matter?


#3

I used standard Game Center plugin in construct 2 and now GC works! [URL=http://hostingkartinok.com/show-image.php?id=b071ce1eb1009c2c30c7afcd1b0c062b][/URL]


#4

Hi guys,

I took note of this bug, but we don’t have the resources at the moment to address it.

The plugin is Open Source so you could try to look for the error. Any help is welcome.

Regards.


#5

I do understand that you are very busy, but this is an official Ludei Plugin which is not working at the moment.
I guess the author / developer of this plugin can fix this issue a way faster than anybody else.
Many C2 developers do pay for their membership and it’s really frustratring to know that such a feature like Game Center doesn’t work anymore.

I do understand both sides, yours and the user side. I hope you’ll find some time to fix this issue.
Moreover the Cocoon Service dosen’t work since for 1 or 2 weeks (several bugs).
So to hear that now, is really frustrating as cocoon user.

Regards
Andy


#6

@Blue_Sialia any news on that?


#7

Hello users,

I poked the developer about this issue again. We’ve had sudden issues with higher priorities but he’s working on this.

Regards.


#8

My issues are solved now.


#9

Thank you!

Regards
Andy


#10

@Blue_Sialia

Have you got any feedback from the developer yet?
It’s been a while since the report of this issue.

Thank you for your assistance!


#11

@Blue_Sialia
Any news on this? It would be great if the Game Center plugin would work again…

thank you!

Regards
Andy


#12

@andy_reitberger
@Ruslan_Abdullach
@Blue_Sialia
@erik.mattias.larsson

Hi, try followings and let me know gc login works or not.

Fix Game Center login error (No plugin but iOS setting problem)

Fix iOS7~ Game Center login error (the requested operation has been canceled or disabled by the user)
: Reenable GameCenter after user cancelled 3 times. (iphone - Setting - General - Reset - Reset All Settings)

Fix iOS8 Game Center login error (The requested operation could not be completed because this application is not recognized by Game Center.)
: Enable Sandbox (Settings–> Game Center --> Sandbox)
But no sandbox menu from iOS9, so you do not need to set sandbox on from iOS9.

Thanks
Sang Ki Kwon

Edited this post


#13

Hi @cranberryga

thanks for the hint, I’ll try this at home.

Thank you!

Regards
Andy


#14

Thanks for testing::grinning:


#15

Hi @cranberryga

I tried it. The issue on my end is, that I’m able to login (the condition CocoonGameCenter “is logged in” is true), but when I call the “Open leaderboard” or “open Achievements” action, I’ll get a blank screen.

Any ideas why this is happening?

Regards
Andy


#16

Hi, Andy

I tested your app (https://itunes.apple.com/de/app/match3-2048/id1111204649?mt=8) in my iPhone 4s (iOS 8.4.1).
Login works. (not tested logout but logout will not work because cocoon does not implemented this feature internally yet.)
Leaderboard and achievement works.
I set sandbox on.
: Enable Sandbox (Settings–> Game Center --> Sandbox)
But no sandbox menu from iOS9, so you do not need to set sandbox on from iOS9.

I made simple test capx and tested.
Login, leaderboard, achievement worked in iPhone 4s (iOS 8.4.1, real device) and Phone 4s (iOS 9.1, simulator).

I guess black screen may be comming from other plugin feature.

Thanks
Sang Ki Kwon


#17

Hi @cranberryga

Thanks for testing. I figured out that it was my device. I just logged off in the settings (like you said, it doesn’t work in the game).

Now login seems to work again, thank you :slight_smile:


#18

Oh good
Have nice weekend.:grinning:


#19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.