Google play console errors


#1

Hello,

Has anyone had any problems with beta testing an app using Google Play Console? I uploaded the APK, which went fine. After which, I chose to beta test got a link to download the app. When I downloaded the app to my Galaxy, it didn’t work…just the Cocoon icon. When I click on the Cocoon icon and enter the URL location of the zip file, that doesn’t work either. I tried it with 2 different apps.

Is there some settings in either Construct 3 or Cocoon that I need to be aware of?

Thanks,
W


#2

Hi!
Did you try it before you uploaded it on Google Play? I lately have built an android version and it works fine. I also uploaded it as Beta on Google Play, however I’m using Construct 2 instead.
Can you try and built an apk with Cocoon, then instead of uploading it to Google Play, transfering it to your android device and try it?

Best,
Andy


#3

Hi Andy,

I built the APK with Cocoon and tried to test it on my Samsung tablet. I opened the APK with with Samsung’s APK download function and it says “This app isn’t compatible with your device”.

I’m probably not transferring the APK correctly to my table….I read your e-book from Scirra and did everything correct up until the testing part on the tablet. Is there a more detail instruction on how to transfer the APK to the tablet for testing?


#4

Hi,
what version have you installed? The arm or the x86? Mostly it’s the arm version.
About your screen shot. The URL you entered must end with “=1”
Otherwise the dropbox link doesn’t pointer to the original file.
So just replace the ending “0” with a “1” and it should download your project.

It’s also important that you need to download the source code, not the “apk” file in the developer app.

Regards
Andy


#5

Hi Andy,

I downloaded the source code after compiling on Cocoon. Then pasted the the Dropbox link replacing “=0” with “=1” as you suggested. When I selected Canvas+ the stays on the “Powered by Cocoon” screen for a few minutes, after which it goes back to the tablet desktop screen. When I selected Webview+ and Webview, it basically does the same think.

If it helps, I’m sharing the link.

Thanks again for your help. As you can see, I’m new to this, so thanks for your patience.

Wil


#6

Andy,

By the way, I forgot to answer your question about arm or X86. I’m not sure, because when I downloaded the source code, only 1 version was available.

Thanks again,
Wil


#7

Hi Wil,

thanks for the attachment. I’ll check it once I’m back on my computer.
About the arm and x86 version. You can activate / deactivate those in your project settings.
Just go to your project, settings, android. There you can choose wether if you you want to get both (arm, x86) or only one of those two.

Regards
Andy


#8

Thank you again, Andy, for all your help!

Perhaps that was one of my issues with Google Play - not using the correct version of the APK. No hurry, but when you get a chance, can you explain what the difference between them is?

W


#9

Hi Wil,
just checked your source code. It seems that you zipped all content of the export.
You just need to zip the content in the “www” folder.
Please see here:

About the two versions.
Mobile devices are using diffrent CPUs, mostly ARM but some (minority) the x86 CPU architecture. This is why you get two diffrent APK files. You cannot run a ARM APK on a device using a x86 CPU and in reverse.
However I personally only use the ARM version. Mostly all devices are using an ARM CPU so far. So you should be good with that.

Let me know if you have any further questions.

Best,
Andy


#10

Hi Andy,

Per your instructions:

-I re-downloaded the source code from Cocoon and zipped only “www” file.
-I re-downloaded the Cocoon developer app from Google Play and pasted the DropBox link (see below), removing the “0” and replacing it with “1”
-Using the Canvas+ (and Webview), one time I get the “Cannot open html file https://www.dropbox…” and another time I get another black screen error…see attached screen shot.

IMG_3190|375x500

Perhaps the file is corrupted somehow, but it was successfully complied via Cocoon, though.

Thanks again,
Wil


#11

Hi Wil,

thanks for your reply. It seems that there is a problem rendering .gif files.
I tried to download your attached zip file,
however it returns a 404 error. Would you mind if you sent me your Construct 2 project file in a private message?
I’ll try to built it at my end.

Thank you!

Best,
Andy


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.