iOS builds are not being signed


Cocoon Version:
Latest browser version.

Basic description of the problem:
I have created an iOS key. It has the following components:

  • p12 certificate (from a production certificate signed by apple set to app store / ad hoc)
  • the export password for the p12 certificate
  • the mobile provision (distribution set to app store)

When I compile my app with the key selected (it is the only iOS key I have) I download the .ipa file. I try uploading it to the app store but Apple tells me the code isn’t signed at all. Upon further investigation myself, it seems that the code really isn’t signed at all.

Expected result:
I expect to get a signed .ipa file after compilation.

iOS IPAs not being signed correctly?
Can't remove user splash and compiler broken

Same problem here, I’ve been reporting this for 3 days now without any feedback…


Hello @austenprobst,

Could this be the bug in Xcode described here?



Those bugs seem to be from 2015, although I note on the Apple forums a few issues from Nov this year?


You can sign your iOS file also with Xcode. Just unselect your key at your cocoon project. Then compile a version and download it on your mac. Then open it with XCode and click “Upload to Store” or “Export” if you first want to install it on your test device.
Both methods will sign your project and latter will output an ipa file.



I unfortunately do not have a Mac to hand, I use OpenSSL to generate certificates / + our Enterprise Apple Developer Account.

So this could be a viable solution (I can’t test it myself right now), but not for PC users.


I believe the bug to be in Cocoon. The reason I believe that is because last week I made an iOS build which used a different key (ad hoc provisioning profile for local testing) and it gave me signed code. The only thing I changed was the provisioning profile which is set to app store distribution and it’s not giving me signed code.

I was able to find a work-a-round to sign it myself on a Mac. Here are the instructions:

to sign .ipa file (Make sure .p12 certificate is installed into Keychain)
rename AppName.ipa to and extract

right click Payload/ and view contents

open Payload/
look for the part that says <key>Entitlements</key> and copy the <dict> element

Create file (/Users/Nathan/Downloads/entitlements.plist) that looks like this (with the correct dict element copied from embedded.mobileprovision):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">

run the command (replace Organization Name (12AB34C5D6) with your certificate name which can be found in your KeyChain):

codesign --force --sign "iPhone Distribution: Organization Name (12AB34C5D6)" --entitlements "/Users/Nathan/Downloads/entitlements.plist" --identifier "com.organization.appname" /Users/Nathan/Downloads/Payload/

compress Payload (should create a
rename to AppName.ipa


I’ve tried now using ad-hoc and distribution profiles through Cocoon, and neither are signing for me.


The latest test I run worked fine to the point of installing the IPA in iOS devices.

I didn’t try to upload the APP to the store though. Can you install the APP? Or do you only have problems uploading it?


Once the IPA is generated I can’t sync it to the device via itunes or OTA deploy it via Diawi. You don’t really get any error’s (thanks Apple) but with itunes it just sits installing, diawi says “the app cannot be installed at this time”.
Previously anytime I’ve had this issue it’s been related to the certificate / signing.


From what I experienced, I couldn’t install the .ipa if it wasn’t signed. So if you can install it, it seems that Cocoon is signing the files again.


Have you tried to remove the currently installed version from your device first?
I’m not sure, but I had a similar issue back then. I didn’t increase the version and so it conflicted with the already installed app on my IPhone.
So I did remove it first and then it worked.




Yes I’ve removed the previous version everytime I re-sync with iTunes or use Diawi. I will try update the version number and rebuild / deploy now and see if anything has changed.


I’ve just re-done the entire process, created new keys/certs/provisioning profiles… built using my old ones and these new ones. Removed previous application, with both sync via itunes or diawi ota install failed.


Do not even try, the compiler is broken - that’s the problem. I can not get an answer on this matter from the team for several days … It’s frustrating … all projects in the stale state


Any update guys ? Still can’t generate signed ios builds.


(I’m just going to post on this thread as well for good measure) … any updates guys?


I want to know status on this issue too.


Hi guys,

Just wanted to confirm you we are working on this issue.



I can confirm rebuilding again solved my issues.