iOS builds are not being signed


@erik.mattias.larsson I did not undertand, is it working now? I just compile an adhoc file and it´s not installing on my ipad, it just says installing…but nothing ever happens


It was working last night but not this morning again, Blue_Sialia and the team are looking into again.


Yesterday I was able to get an IPA file that did not throw the error “Missing or invalid signature” error when submitting the IPA file using the Application Loader (although the file was rejected due to an issue related to “NSPhotoLibraryUsageDescription”).

However today I made a new build and I’m getting the same error again: "Missing or invalid signature. The bundle 'xxxx' at bundle path 'xxxxxx' is not signed using an Apple submission certificate."


Hello users,

We are preparing a solution. I’ll update you here when it is live.

Remember you can sign locally too.



Hi, is there any update on this solution? Thanks.


Also interested to know.

My apps are stuck on installing when trying to install Adhoc IPA on device. Is this what others are experiencing too? I’ve double checked my certs as I thought that could be the issue but I’ve had successful builds in the past!



We are still working on this issue. I have no ETA, but the team is making progress.



@Blue_Sialia I have to say, given that this service has been down for almost a month now, your reply is not particularly reassuring.


Just a note that Apple will stop accepting app submissions by the end of this week, so if this issue is not sorted out in the next 24 - 36 hours we will not be able to update our apps this year. @Blue_Sialia any update on progress? Regards.


anything yet?? any progress?


Really guys? No update at all?


Hello guys,

The bug is now fixed and the IPAs should work as intended.

Thank you for your patience.


I´m trying today and the bug seems to be back, when I try to install the iap on my ios decive it just keep saying installing, anyone else having this problem?


Can you try the cocoon version “2.1.0 (beta)”? Does it happen there as well?



I tried the 2.1.0(beta) the compilation worked, but it still just say installing, and now I can´t compile anymore because I get the keychain error, which is strange, I used the same p12 file just earlier and it worked, I´ll check my certificates to be sure

==== UPDATE======
Well I changed the p12 password and now it works, nevermind my problems! Thanks for the attention Andy!


This could be because Cococon v2.1.0 is using XCode 8 now (as far as I know). And so maybe you just need to re-enter your password.
But I’m glad that it is working now :slight_smile:



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.