iOS Canvas+ - Appstore throws ITMS-90542.. Info.plist looks weird


#1

This happens on a compile for a C2 app in my case. I’m seeing this on both Canvas+ 2.10 and 2.20. I do not use 3.x.
It was fine a few days ago. I switched to see if Webview+ would compile and, after switching back a couple of days later… I see this issue. It prevents the app from going to TestFlight. The offending file is the Info.plist within the .ipa file, inside debugservicebundle.bundle.

I resolved it by copying the Info.plist from a compile I did a few days ago. I don’t see what I could have done on my end to generate a different Info.plist like that from just a couple of tiny, subtractive tweaks in my app.

Here is a screenshot of the plist I was seeing before and after. My canvas+ compilations are now spitting out the “simulator” values you see on the right. So I’m replacing the file on the right with the one on the left.

So, I’ve got a workaround… I’m just curious if anyone else is seeing it… on the off chance that this problem is something I did and not server-side.

Full Error:
iTunes Store Operation Failed
ERROR ITMS-90542: “Invalid CFBundleSupportedPlatforms value. The key ‘CFBundleSupportedPlatforms’ in the Info.plist file in bundle ‘Payload/PT Keys.app/DebugServiceBundle.bundle’ contains an invalid value ‘[iPhoneSimulator]’. Consider removing the CFBundleSupportedPlatforms key from the Info.plist. If this bundle is part of a third-party framework, consider contacting the developer of the framework for an update to address this issue.”


#2

Got same error few days ago, made same trick to bypass it.


#3

Hello!
How can i find and open this file? i have only .ipa file


#4

i changed values in this file to correct, but now application loader throws ERROR ITMS-90174: “Mising Provision Profile” - Apps must contain a provisioning profile in a file named embedded.mobileprovision."

Help pleaseeee, what i need to do?


#5

Your new problem could be unrelated to the rest of this thread. I personally have resolved this by never using the automatic option for XCode to sign a package. I choose manually. If the problem persists, I would make sure you’ve tried everything that comes back on google results, especially if you have not ever gotten the signing to work yet.


#6

i am not using xcode to signing at all.
i export project from my construct 2 , upload zip to cocoon , choose ios key , compile and send to app store with applicatoion loader.


#7

having this issue as well now… Never had this issue before. I’m compiling with canvas+ loaded the xarchive for signing edited the values in debugservicebundle.bundle to iphoneos YET it still states this issue… Getting really ridiculous…


#8

still not submiting(
any ideas?)