iOS compile now consistently produces strange .ipa folder


Update: This appears to be a dup of another post (a bug report, also posted today)

Has anyone been able to export to iOS using a signing key (to create an .ipa file)?

  • Cocoon Version:
    2.1.0, 2.2.0, latest

  • Basic description of the problem:
    When compiling a Construct2 Cordova export for iOS and using a signing key, Cocoon will produce a .zip result that does not contain an .ipa file, but rather an .ipa folder within an archive that appears to be corrupt or malformed.

Despite the being about 30MB, the archive only shows and extracts only the below 3 files, which only amount to about 69KB.

The folder contains only these 3 files.

This workflow has been great for months. All I’ve done is upload a new build from Construct and it no longer works. I understand that the .ipa file is basically an archive itself, so that isn’t part of the confusion. I’ve tried different Cocoon versions, archive utilities… created a new signing key… something appears to have changed server-side.

I’m using Windows 10 for the most part. if I try to extract the on a mac, I get an “Error 2”.

  • Device info:
    Windows 10, El Capitan.

  • Steps will reproduce the problem:

  1. Export something to Cordova using Construct r255
  2. Compile it in Cocoon for iOS, using a known good signing key.
  3. Observe the result zip file produced
  • Expected result:
    I’m expecting a .ipa file that I can load onto my iPad for immediate as has always been the case.
    I use the same certificates and Construct export that have been working for several months… creating a new signing key does not seem to help.

  • Error log
    The compilation is successful, I just don’t get an .ipa file inside the as I did before. I get a folder

  • Testcase:

  • Other information:
    see inline

  • Webview engine(s):
    Canvas +
    (Also happens on Webview, Webview+)

  • Used plugins (if relevant):

  • Framework/game engine (if relevant):
    Construct 2 r255

[BUG] iOS compilations giving corrupted .ipa files

The same thing happened to me! Have you found out what is causing this?


iOS compilations giving corrupted .ipad files


Do you know why that is and when it will be fixed?


Same here, it gives the Zip file but when I extracted it gives just a folder with .ipa at the end of the name but not the proper ipa, the strange thing is when you open the zip you can see the ipa there inside but you cant Extract it


same here tried all canva+, webview, webview+ I think the back end cordova compiler is broken. Do you know when this will be fixed?


I’m having the same problem with my app, that’s been compiling fine for months. I also only can get a folder with:


I cannot find any new information or acknowledgement of this issue but just tried a compilation a few moments ago and the problem still exists.


I also re-tried it a few minutes ago and nothing has changed. Very frustrating, maybe it’s time to switch to Phonegap. I’ve never tried it, do anyone of you have any experience with Phonegap?


I reuploaded my files and recompiled, but I’m still having the same problem.


seems to be a server / compiler problem. I assume Ludei is already on it.
As long this issue is up, you can still unselect your certificate at your cocoon project.
So you will get a .xcodearchive instead of an .ipa file.
This archive can be opened with Xcode and then exported to an ipa file or uploaded directly to the apple store.


Html5 to xcode issue

Hi Andy!

Is it possible to do that on a Windows-computer? If not, that doesn’t really help me :frowning:


Sadly no. This requires a Mac computer running XCode on it.


I’m still experiencing this issue. Any idea when it will be fixed?


I tried this and it allowed me to sign the app and to upload it but failed due to missing icon. I checked and the app has an icon setup but its not being added to the ipa.



Hi again Andy! Do you have any idea when this problem will be fixed? It’s been a month now :frowning:


Sadly no, hopefully @Blue_Sialia can give as an ETA?



Thank you for your reply, I really appreciate it. Hopefully it will work soon because I am so eager to upload my games to App Store :slight_smile:




We are facing the same issue here now too. I had to re-create all my provisioning profiles and keys for some reason as it wouldn’t compile the iOS build at all, but having done that I now receive a corrupted archive too which just has sub-folders / files and no valid IPA.

I’ve spoken to Imanol, and am hoping there is a resolution very quickly!



We haven’t been able to reproduce the issue where the result zip is corrupted with no valid IPA inside, but we have made some changes in the process to make it more robust.

Now you should receive only the IPA file. Let us know if there is still some issues.