Issue with png files with gradients on iOS


#1
  • Cocoon Version:
    Latest

  • Basic description of the problem:
    I do use a png file with a gradient in my latest game. It looks perfect on Android, but strange on iOS. Both uses Canvas+

  • Device info:
    Iphone 5s

  • Expected result:
    What’s the expected result.

  • Testcase:
    Here is my image (png-32).

bloody_sky_gamescreen-ps.zip (4.5 KB)

  • Other information:
    Here are two screenshots, one from my Iphone 5S and one from my Samsung Galaxy S4

Iphone

Samsung S4

  • Webview engine(s):
    Canvas+

  • Framework/game engine (if relevant):
    Construct 2


#2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


#3

#4

@Blue_Sialia any news on this? It’s been a while.

Thank you!


#5

+1 This is still an issue, any gradients In Canvas+ iOS will have a banding issue whereas Android works like a charm.
Not seen any good results even when using gradient dithering via Photoshop.
Hope this gets a response.


#6

i have same problem, any news for this? we can fix this?


#7

I haven’t tried it since then. Maybe the new cocoon beta version fixes this issue.
I ended up removing the gardient background for my game back then.

@Blue_Sialia any news on that?

Regards
Andy


#8

I still have issue with the gradient rendering. When I change canvas + to webview gradient rendering fine.


#9

Is your png 32bit ? i had this issue one time with 8bit png with transparency before (but on android), and no more in 32bits


#10

Nope, still having an issue with CANVAS+ but not with Webview+.
Any solutions?


#11

Yes the issue is related to Canvas+ only.
@Blue_Sialia any updates on this?

Regards
Andy


#12

@Blue_Sialia @andoni.martin @imanolm1
Any hope to get this fixed? It still happens.

Thank you!


#13

Any news? This is a very serious problem … why has nobody been paying attention to this for so long?


#14

Found this issue today on iOs no matter the bit depth. Looks ok in android.


#15

This is still an issue right now :frowning:


#16

Sadly yes :frowning:
Any chance to address this in the next update? @Blue_Sialia

Thanks!


#17

We’re freaking out here, our game looks horrible on iOS and we are launching in 4 days and WebView+ just fails to compile…


#18

What error do you get while compiling for WebView+?

Regards
Andy


#19

Hi Andy! We’re using Canvas+ but I tried to recompile with WebView+ for you. Here’s what I got:

COMPILER ERROR:

Failed to fetch plugin https://git-wip-us.apache.org/repos/asf/cordova-plugin-file.git via git.
Either there is a connection problems, or plugin spec is incorrect:
Error: git: Command failed with exit code 128 Error output:
Cloning into ‘/tmp/git/1512787595716’…
fatal: repository ‘https://git-wip-us.apache.org/repos/asf/cordova-plugin-file.git/’ not found

CORDOVA LOG:

e[36m[2017-12-08 18:45:59.324] [DEBUG] IOSBuilder - e[39m[prepare] cordova restore platforms
e[36m[2017-12-08 18:45:59.337] [DEBUG] IOSBuilder - e[39m[prepare] adding engine ios@4.3.0
Ignoring: Contents.json
Contents.json is not a valid image
e[36m[2017-12-08 18:46:32.403] [DEBUG] IOSBuilder - e[39m[prepare] cordova restore plugins
e[36m[2017-12-08 18:46:32.407] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin cocoon-plugin-ads-android-admob@*
e[36m[2017-12-08 18:46:32.444] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin cocoon-plugin-ads-ios-admob@*
e[36m[2017-12-08 18:46:32.476] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin cocoon-plugin-inapps-android-googleplay@*
e[36m[2017-12-08 18:46:32.529] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin cocoon-plugin-inapps-ios-appstore@*
e[36m[2017-12-08 18:46:32.561] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin com.ludei.canvasplus.android@2.3.8
e[36m[2017-12-08 18:46:32.631] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin com.ludei.defaultres.ios@1.1.1
e[36m[2017-12-08 18:46:32.730] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin com.ludei.usericon.ios@1.0.1
e[36m[2017-12-08 18:46:32.779] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin com.ludei.usersplash.ios@1.0.3
e[36m[2017-12-08 18:46:33.520] [DEBUG] IOSBuilder - e[39m[prepare] adding plugin com.ludei.webviewplus.ios@1.1.0
e[36m[2017-12-08 18:46:36.689] [DEBUG] IOSBuilder - e[39mFailed to fetch plugin https://git-wip-us.apache.org/repos/asf/cordova-plugin-file.git via git.
Either there is a connection problems, or plugin spec is incorrect:
Error: git: Command failed with exit code 128 Error output:
Cloning into ‘/tmp/git/1512787595716’…
fatal: repository ‘https://git-wip-us.apache.org/repos/asf/cordova-plugin-file.git/’ not found