Ludei is not updating the bundle version with the provided one

  • Cocoon Version:

  • Basic description of the problem:
    Im getting an error from apple when uploading. It seems that the Ludei’s Bundle Version is not updating.
    My current App Store version is 63. I just set the bundle version to 64 in ludei’s app control panel.
    However at compiling (as version 64) and later uploading to apple, Apple returns me an error that the version still on bundle 63, and it should be grater than 63. I already tried to set bundle to 65 66 and on but not changes.

Here are the ludei configuration.

the CFBundleVersion is set to 64

and here is the apple store error. telling me that the version i just uploaded had bundle version [63]

Just in case, here is the latest uploaded package in the apple store.

It seems that ludei is not updating the bundle version with the provided one, and keeping the last one.


You must update this version manually. Otherwise each build would increase this number. But this is only necessary if you upload a new version to the store. So once you’ve uploaded a new version, increase this number by 1.
The same applies to the version code for the Android build.



As you can see in my description and screenshots. I already update the version manually. however it has no effect in the final compiled package.


Sorry for the missunderstanding. Can you check your config.xml file at your cocoon project?
If you enter the value there, does it work then for you?



OK. my XML shows me a new version [64] also.

<widget xmlns="" xmlns:cdv="" xmlns:cocoon="" id="com.diastudio.joinjelly" version="1.510" android-versionCode="64" ios-CFBundleVersion="64">


And if you compile a new version it still says 63?
It’s strange when the value is acurate in the config file but not in the final build.

Can you give it another try? Otherwise @andoni.martin should have a look at this matter.

Thank you!



Same error
Package Summary:

1 package(s) were not uploaded because they had problems:
/var/folders/zr/zv79cstn7f33jy8t6v7_6wdw0000gn/T/B50EFA5A-21DA-44A1-BEEF-5B2AA0E26443/981743649.itmsp - Error Messages:
ERROR ITMS-90478: "Invalid Version. The build with the version “63” can’t be imported because a later version has been closed for new build submissions. Choose a different version number."
ERROR ITMS-90062: “This bundle is invalid. The value for key CFBundleShortVersionString [1.510] in the Info.plist file must contain a higher version than that of the previously approved version [63].”


Hi @artsjedi

in this case we need to wait till ludei has returned from their holidays.
@andoni.martin will check or forward this to the person in charge.

Thank you!



I’m still having this issue


Hi @artsjedi

@Blue_Sialia is there a chance to check that?
Thank you!




Sorry for the late response, but here the App Store is telling you CFBundleShortVersionString is smaller than 63. In your image CFBundleVersion is 64, but CFBundleShortVersionString is not.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.