Operation Failed: Reason: Invalid format of package field



When trying to export one of my Construct 2 apps to Cordova the zip file always fails in Cocoonio.

The app has physics behaviour and touch which I think should all work?


Sorry for the late respone, but the physic bug should be fixed now and you should be able to build your games now.



Andy, I have the same problem, i can’t export my app.

Help me please!


Can you please PM me your capx file? What Construct 2 license do you have?



"Operation failed
Reason: Invalid zip file."
I have the same problem, May you help me?


operation failed: Reason: Invalid zip file.
always error


Can you attach your zip file? So I can test it on my end?

Thank you!



I found my mistake …
my file “.json” contained spaces example (my file.son),

I renamed the file (my_file.json or myFile.json) and it worked


I have the same problem. I tried to upload my project many time and everytime it says: operation failed
Reasone: Invalid format of package field.
what does it mean ? :frowning:
what I have to do?



Can you send a screenshot of the content from the zip file you were trying to upload?

Thank you!


I didnt add any media to my project so I dont have it in the content! even I added an empty media folder and tried again but it didnt work anyway :frowning:


I found it :innocent::sunglasses:
I’ve entered numbers in Bundle Id ! which is not supported I think.
You have to not using numbers in the Bundle Id.

Thank guys


Yes that’s accurate. I’m glad that it’s working now :slight_smile:



I’m also having this problem, I’m uploading a new version the a game I made, and it keeps telling me the zip is invalid.
I managed to solve it by changing some sprite name from hebrew to english, and now it works.
Any chance hebrew or any other non-latin languages that may be crashing it will be supported in the future?


where is bundle id? i 've same problem like you


@yarden11111 @ayuastutikartika

In C2 it called just “ID”, It’s in properties bar, if you dont see properties go to view tab and enable it.


For me it was a - in my bundle id. Chaging to an _ fixed the issue


This ID in C2 isn’t important, at least if you delete the config.xml file coming from C2 before you zip the output and upload it.
Otherwise check the bundle ID in your Cocoon project settings.



Não consigo enviar , erro Operation failed
Reason: Invalid zip file. …


Hey people, I already changed my project ID, but it still giving me this error “invalid .zip file”, can anyone point me a solution?