[SOLVED] Cordova-plugin-file not installed


#1

So I have cordova-plugin-file as a part of my plugins, and it’s also listed in the config.xml, but after compiling it’s neither found in the plugins directory of the app, or listed in cordova_plugins.js.

Is this a known issue, or is anyone else experiencing this with this plugin? All other plugins seem to work fine…


#2

Could it be related to this error message that others are experiencing (“Error fetching data.js”):

Have you seen this thread: Black Screen on iOS (Construct 3 project) the op mentions ‘Cordova-plugin-file’ as not being read as well.


#3

I think it’s something with the most recent version of the plugin itself. I just managed to get the plugin installed when I locked the version down to 4.3.3 in the config.xml.

Not having build logs in case of a successful build is hurting my progress though…


#4

Hey @Str1ngS thanks for the info, can I ask why did u choose to set the version at 4.3.3 which is several versions back?


#5

I compared the change log of the plugin (https://github.com/apache/cordova-plugin-file/blob/master/RELEASENOTES.md) with my last successful build with the plugin. Maybe 5.0.0 also works.