[Solved] Having problems building Construct 2 game


#1

Hey guys,

I’ve been trying to compile/build my game that has been exported from construct 2.

I have no additional plugins other than the original Construct 2 plugins but I continuously get this error when attempting to compile

CORDOVA LOG:

e[36m[2018-01-30 17:04:05.735] [DEBUG] AndroidBuilder - e[39m[prepare] cordova restore platforms
e[36m[2018-01-30 17:04:05.748] [DEBUG] AndroidBuilder - e[39m[prepare] adding engine android@6.2.3
Subproject Path: CordovaLib
Subproject Path: CordovaLib
(node:15876) DeprecationWarning: ‘root’ is deprecated, use 'global’
e[36m[2018-01-30 17:04:18.838] [DEBUG] AndroidBuilder - e[39mundefined

I am using the latest version of Construct 2 and the latest version of Cocoon and trying to export to Android.
I’ve followed the guides but still run into this problems every time.

Any help on the matter would be greatly appreciated.

Thanks,
Josh


#2

Just made an android built with my Construct 2 game project. Worked fine for me.
What cocoon version are you using?

Regards
Andy


#3

I’m using version 2.2.0, I have also tried just using the pre-made example games from Construct 2 to build and I am encountering the same error for them too.

The only thing of mine that I notice is different from the guides I have read, is that when the game is exported file structure looks differnent, not sure if this is because I have the latest version of construct 2.

All files but config.xml and config.json are in a file named www.


#4

I have sorted it.

I moved all the files outside of the www folder and deleted it and then deleted the config.xml and config.json files.

Works like a charm.


#5

You also just can zip the content in the “www” folder though.

Regards
Andy


#6