[SOLVED] Unable to compile custom developer app

#1

Hello Cocoon.io community,

The “compile developer app” button(s) in my project’s dashboard doesn’t seem to do anything. There’s a “loading” circle animation playing on it for a few seconds, then nothing. No success (or failure) message, no email either. I have selected Android platform for the project. Am I missing something? I’ve tried this on Firefox and Chrome, OS is windows 7.

0 Likes

#2

Hello @marcantoupin,

I just tried it and works for me.

Does it work with iOS? Does it happen with a specific project or all of them? What about the normal compilation? Do you have any extension that may intercept any HTTP request (Ad Blocker, HTTPS enforcer…)?

Regards

0 Likes

#3

Thanks for the assistance @Blue_Sialia .

No extension of the like, no. I tried the same thing from the browser on my iphone, same result. So it probably has to do with the projects. I get the same result for all of them, both for Android and IOS, but I should say that those are all projects that were migrated from the CocoonJS era.

I’m trying to setup a new project, but I’m facing a new problem here: When dragging my zip file in the appropriate space to upload it, I get “Operation failedReason: There was a problem processing your config.xml file.” at the end of the upload. There’s no config.xml file in the zip. This happens even with a very simple zip file containing only a blank html file. I do zip only the content of the folder, not the folder itself, as said in the documentation. Are there new requirements for zip files that didn’t exist before Cocoon.io ?

EDIT: The migrated projects didn’t have source code associated to them. I managed to upload a zip file to replace the source code of one of them, and compilation of the dev app (and presumably, normal compilation) seems to be working now. I still get the same issue trying to create a new project from the same zip, though.

0 Likes

#4

I solved the problem by copying the content of config.xml of an existing project in a new config.xml, which I included in the zip file. All good now AND I’m pretty pleased with the resulting app.

However, I don’t see it mentionned in the documentation (specifically, in “Getting started”) that a config.xml file is required in the zip folder. If I hadn’t already had existing projects handy, it would have been pretty hard to figure out how to set it up.

0 Likes

#5

Hello @marcantoupin,

A config.xml file is not necessary to create a project. Could you send me your zip file so I can test it myself?

Thank you

0 Likes

#6

Must have been a temporary glitch. It works fine now. Thanks!

0 Likes

closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes