Splash Screen Issues


Try enabling Multidex in your Android settings.


Multidex like in the settings for Compiling?


Settings -> Android -> Multidex enabled “yes” at your cocoon settings.

Your screenshot shows a strange file format?
Can you turn “show known file extensions” on at your folder options in windows?
Does the file end with .apk?



Yep, it ends with .apk. Those files with the messed up icons are .apk . Multidex didn’t work, either.


Can you share a test case then?
Otherwise it’s vey difficult to find a solution.
Also attach the config.xml file (can be found in your cocoon settings tab).
You can send it via a PM.



This is an empty project from v244 of construct and it only shows black screen


Can you attach this project? I need to check the settings.

Thank you


Here is a v244 empty project zip file (Not APK) you can test it in cocoonDevApp


Have you ever tried it on a real device? I can remember problems with the nox app player.
I’ll check your capx file at home.



Yes, i tried it on real device and result is the same (Still Black Screen)


I’ll share a minimalistic capx file later. Please try this file then.



Have you tried my example capx? What happened?


Just to toss in my own two cents - I was having this problem this week as well. As a test I compiled an existing project in cocoon where I have created a working APK previously. No changes, didn’t upload a new zip, just hit compile on something that worked as of 5/13 as is and I got the black screen when I loaded the created APK on my phone. Next I tried to compile as cocoon version 2.0.0 instead of ‘latest’ and the APK worked correctly.


I haven’t had time to check it yet. I’m currently full with custom jobs.
I’ll give it a try after work.



I also compiled a construct 2 project with webview+ and it is working fine if don’t upload a splash screen, but if i compile same project with splash screen uploaded in cocoon, the game shows black screen .
I think there is a problem in cocoon’s splash screen mechanism!


Hi @shubhamrathi61195

I’m using also a splash screen on my end with C2 and I got no black screen.
But what I realized is, if you are using a wrong formatted color hex code.

For instance:

#fff <- gives blackscreen
#ffffff <- gives no blackscreen

Can you try that?


You forgot my concern :frowning:


I’m using a splashscreen for my game and it’s working fine. So I guess it’s not a general error with the splash screen.
Maybe it’s just a wrong configuration.



Sorry for late reply! i just saw your comment,
It worked! :slight_smile: